Don't compile the sync directory
[lttv.git] / lttv / lttv / Makefile.am
index 170f4d5bd3d48d35c52538da70cf0435bb7bd1f9..f7a93ca32853848ba9bf658ba8dcafc1fb9a427c 100644 (file)
@@ -1,13 +1,24 @@
-AM_CFLAGS = $(GLIB_CFLAGS) 
-LIBS += $(THREAD_LIBS)
-LIBS += $(POPT_LIBS) $(GLIB_LIBS) -lgobject-2.0 -L${top_builddir}/ltt\
-          -llttvtraceread
+#BABEL_CLEANUP
+#SUBDIRS= sync
+
+AM_CFLAGS= $(PACKAGE_CFLAGS)
+LDADD = $(POPT_LIBS) $(M_LIBS) $(GLPK_LIBS)
 
 bin_PROGRAMS = lttv.real
 
+if BUILD_LTTV_GUI
 bin_SCRIPTS = lttv lttv-gui
+else
+bin_SCRIPTS = lttv
+endif
+
 CLEANFILES = $(bin_SCRIPTS)
+
+if BUILD_LTTV_GUI
 EXTRA_DIST = lttv.sh lttv-gui.sh
+else
+EXTRA_DIST = lttv.sh
+endif
 
 lttv: lttv.sh
        rm -f lttv
@@ -24,11 +35,63 @@ lttv-gui: lttv-gui.sh
 
 INCLUDES = \
        -DPACKAGE_PLUGIN_DIR=\""$(lttvplugindir)"\" \
-       @PACKAGE_CFLAGS@ \
        $(DEFAULT_INCLUDES)
 
 libdir = ${lttvplugindir}
 
+#noinst_HEADERS = \
+#      filter.h
+
+#disabled for babeltrace port  batchtest.c stats.c     tracecontext.c  filter.c
+
+
+
+lttv_real_SOURCES = \
+       main.c\
+       module.c\
+       option.c\
+       hook.c\
+       attribute.c\
+       iattribute.c\
+       state.c\
+       traceset.c\
+       traceset-process.c\
+       print.c\
+       event.c
+#      sync/sync_chain.c\
+       sync/sync_chain.h\
+       sync/sync_chain_lttv.c\
+       sync/sync_chain_lttv.h\
+       sync/graph_functions.c\
+       sync/graph_functions.h\
+       sync/data_structures.c\
+       sync/data_structures.h\
+       sync/event_processing.h\
+       sync/event_processing_lttng_common.c\
+       sync/event_processing_lttng_common.h\
+       sync/event_processing_lttng_standard.c\
+       sync/event_processing_lttng_standard.h\
+       sync/event_processing_lttng_null.c\
+       sync/event_processing_lttng_null.h\
+       sync/event_matching.h\
+       sync/event_matching_broadcast.c\
+       sync/event_matching_broadcast.h\
+       sync/event_matching_distributor.c\
+       sync/event_matching_distributor.h\
+       sync/event_matching_tcp.c\
+       sync/event_matching_tcp.h\
+       sync/event_analysis.h\
+       sync/event_analysis_chull.c\
+       sync/event_analysis_chull.h\
+       sync/event_analysis_eval.c\
+       sync/event_analysis_eval.h\
+       sync/event_analysis_linreg.c\
+       sync/event_analysis_linreg.h\
+       sync/factor_reduction.h\
+       sync/factor_reduction_accuracy.c\
+       sync/factor_reduction_accuracy.h\
+       sync/lookup3.h
+
 lttvinclude_HEADERS = \
        attribute.h\
        hook.h\
@@ -38,18 +101,14 @@ lttvinclude_HEADERS = \
        option.h\
        state.h\
        stats.h\
-       tracecontext.h\
+       traceset-process.h\
        traceset.h\
        filter.h\
-       print.h
-
-#noinst_HEADERS = \
-#      filter.h
-
-lttv_real_SOURCES = batchtest.c main.c module.c option.c \
-               hook.c attribute.c \
-               iattribute.c state.c stats.c \
-              tracecontext.c traceset.c filter.c print.c
+       print.h\
+       compiler.h\
+       time.h\
+       event.h\
+       trace.h
 
 #man_MANS = lttv.1
 #EXTRA_DIST = lttv.1
@@ -62,6 +121,6 @@ lttv_real_SOURCES = batchtest.c main.c module.c option.c \
 lttv_real_LDFLAGS = -export-dynamic
 
 if LTTVSTATIC
-  lttv_real_LDFLAGS += -profile -static
+  lttv_real_LDFLAGS += -static
 endif
 
This page took 0.024778 seconds and 4 git commands to generate.