Add missing files to distribution
[lttng-ust.git] / tests / ust-elf / Makefile.am
index 92337e769248e60c9a6a526b7099d7c920442380..d14f03f7cc777a67eb7621368585173a09f91794 100644 (file)
@@ -1,14 +1,11 @@
 AM_CPPFLAGS = -I$(top_srcdir)/include -I$(top_srcdir)/tests/utils
 
-noinst_PROGRAMS = prog
-prog_SOURCES = prog.c
-prog_LDADD = $(top_builddir)/liblttng-ust/liblttng-ust.la \
+noinst_PROGRAMS = ust-elf
+ust_elf_SOURCES = ust-elf.c
+ust_elf_LDADD = $(top_builddir)/liblttng-ust/liblttng-ust.la \
        $(top_builddir)/tests/utils/libtap.a
 
-noinst_SCRIPTS = test_ust_elf
-CLEANFILES = $(noinst_SCRIPTS)
-EXTRA_DIST = test_ust_elf.in $(srcdir)/data/**
-
-$(noinst_SCRIPTS): %: %.in
-       sed "s#@ABSTOPSRCDIR@#$(abs_top_srcdir)#g" < $< > $@
-       chmod +x $@
+# Directories added to EXTRA_DIST will be recursively copied to the distribution.
+EXTRA_DIST = \
+       $(srcdir)/data \
+       README.md
This page took 0.022624 seconds and 4 git commands to generate.