Add missing files to distribution
[lttng-ust.git] / tests / ust-elf / Makefile.am
index 203272ed155d7a057ebdd7ab832aaea06ab08f45..d14f03f7cc777a67eb7621368585173a09f91794 100644 (file)
@@ -1,28 +1,11 @@
 AM_CPPFLAGS = -I$(top_srcdir)/include -I$(top_srcdir)/tests/utils
 
-noinst_PROGRAMS = prog
-prog_SOURCES = prog.c
-prog_LDADD = $(top_builddir)/liblttng-ust/liblttng-ust.la \
+noinst_PROGRAMS = ust-elf
+ust_elf_SOURCES = ust-elf.c
+ust_elf_LDADD = $(top_builddir)/liblttng-ust/liblttng-ust.la \
        $(top_builddir)/tests/utils/libtap.a
 
-noinst_SCRIPTS = test_ust_elf
-CLEANFILES = $(noinst_SCRIPTS)
-EXTRA_DIST = test_ust_elf.in \
-       $(srcdir)/data/main.c \
-       $(srcdir)/data/aarch64_be/main.elf \
-       $(srcdir)/data/aarch64_be/main.elf.debug \
-       $(srcdir)/data/armeb/main.elf \
-       $(srcdir)/data/armeb/main.elf.debug \
-       $(srcdir)/data/x86/main.elf \
-       $(srcdir)/data/x86/main.elf.debug \
-       $(srcdir)/data/x86_64/main.elf \
-       $(srcdir)/data/x86_64/main.elf.debug \
-       $(srcdir)/data/pic/hello.exec \
-       $(srcdir)/data/pic/hello.pie \
-       $(srcdir)/data/pic/hello.pic \
-       $(srcdir)/data/pic/hello.c \
-       $(srcdir)/data/pic/libhello.c
-
-$(noinst_SCRIPTS): %: %.in
-       $(SED) "s#@ABSTOPSRCDIR@#$(abs_top_srcdir)#g" < $< > $@
-       chmod +x $@
+# Directories added to EXTRA_DIST will be recursively copied to the distribution.
+EXTRA_DIST = \
+       $(srcdir)/data \
+       README.md
This page took 0.022888 seconds and 4 git commands to generate.