Fix: Don't override user variables within the build system
[lttng-ust.git] / tests / trace_event / Makefile.am
index dcf23a77c9c4f56c3b04dd7cbf25eab57082bd27..2105a181ef2c505833ec62ebe6ae6a57cb432ea6 100644 (file)
@@ -2,8 +2,9 @@ AM_CPPFLAGS = -I$(top_srcdir)/include
 
 noinst_PROGRAMS = trace_event_test
 trace_event_test_SOURCES = trace_event_test.c trace_event_test.h
-trace_event_test_LDADD = $(top_builddir)/libust/libust.la $(top_builddir)/libust-initializer.o
+trace_event_test_LDADD = $(top_builddir)/libust/libust.la \
+                        $(top_builddir)/libust-initializer.o -lpthread -lrt
 
-CFLAGS_trace_event_test.o = -I$(src)
+CFLAGS_trace_event_test.o = -I$(src) $(AM_CFLAGS)
 noinst_SCRIPTS = run
 EXTRA_DIST = run
This page took 0.022986 seconds and 4 git commands to generate.