Use a variable to select the dlopen lib in Makefiles
[lttng-ust.git] / tests / hello / Makefile.am
index e26d949e32921bf936dcac05e5d4e5d06ac83633..d5e42d331eb41d4b62677a74cc04f3dbfb71a624 100644 (file)
@@ -1,9 +1,6 @@
-AM_CPPFLAGS = -I$(top_srcdir)/include -I$(top_srcdir)/libust
+AM_CPPFLAGS = -I$(top_srcdir)/include -I$(top_builddir)/include -Wsystem-headers
 
 noinst_PROGRAMS = hello
-hello_SOURCES = hello.c tp.c tp.h
-hello_LDADD = $(top_builddir)/libust/libust.la \
-       $(top_builddir)/libust-initializer.o
-
-noinst_SCRIPTS = run
-EXTRA_DIST = run
+hello_SOURCES = hello.c tp.c ust_tests_hello.h
+hello_LDADD = $(top_builddir)/liblttng-ust/liblttng-ust.la $(DL_LIBS)
+hello_CFLAGS = -Werror=old-style-definition $(AM_CFLAGS)
This page took 0.023753 seconds and 4 git commands to generate.