Use a variable to select the dlopen lib in Makefiles
[lttng-ust.git] / tests / hello / Makefile.am
index 9afe38742fcaf236350f568906849051b44aafee..d5e42d331eb41d4b62677a74cc04f3dbfb71a624 100644 (file)
@@ -1,8 +1,6 @@
-AM_CPPFLAGS = -I$(top_srcdir)/include
+AM_CPPFLAGS = -I$(top_srcdir)/include -I$(top_builddir)/include -Wsystem-headers
 
 noinst_PROGRAMS = hello
-hello_SOURCES = hello.c tp.c tp.h
-hello_LDADD = $(top_builddir)/liblttng-ust/liblttng-ust.la
-
-noinst_SCRIPTS = run
-EXTRA_DIST = run
+hello_SOURCES = hello.c tp.c ust_tests_hello.h
+hello_LDADD = $(top_builddir)/liblttng-ust/liblttng-ust.la $(DL_LIBS)
+hello_CFLAGS = -Werror=old-style-definition $(AM_CFLAGS)
This page took 0.023313 seconds and 4 git commands to generate.