Add missing files to distribution
[lttng-ust.git] / tests / hello / Makefile.am
index e26d949e32921bf936dcac05e5d4e5d06ac83633..d249909cfb65ba40feaa641ff6b0ea0bff1aeebc 100644 (file)
@@ -1,9 +1,8 @@
-AM_CPPFLAGS = -I$(top_srcdir)/include -I$(top_srcdir)/libust
+AM_CPPFLAGS = -I$(top_srcdir)/include -I$(top_builddir)/include -Wsystem-headers
 
 noinst_PROGRAMS = hello
-hello_SOURCES = hello.c tp.c tp.h
-hello_LDADD = $(top_builddir)/libust/libust.la \
-       $(top_builddir)/libust-initializer.o
+hello_SOURCES = hello.c tp.c ust_tests_hello.h
+hello_LDADD = $(top_builddir)/liblttng-ust/liblttng-ust.la $(DL_LIBS)
+hello_CFLAGS = -Werror=old-style-definition $(AM_CFLAGS)
 
-noinst_SCRIPTS = run
-EXTRA_DIST = run
+EXTRA_DIST = README
This page took 0.023815 seconds and 4 git commands to generate.