Add missing files to distribution
[lttng-ust.git] / tests / hello / Makefile.am
index 847e64d907200685a2f3a8c41560bf19f835bbce..d249909cfb65ba40feaa641ff6b0ea0bff1aeebc 100644 (file)
@@ -1,15 +1,8 @@
-AM_CPPFLAGS = -I$(top_srcdir)/include -Wsystem-headers
+AM_CPPFLAGS = -I$(top_srcdir)/include -I$(top_builddir)/include -Wsystem-headers
 
 noinst_PROGRAMS = hello
 hello_SOURCES = hello.c tp.c ust_tests_hello.h
-hello_LDADD = $(top_builddir)/liblttng-ust/liblttng-ust.la
+hello_LDADD = $(top_builddir)/liblttng-ust/liblttng-ust.la $(DL_LIBS)
+hello_CFLAGS = -Werror=old-style-definition $(AM_CFLAGS)
 
-if LTTNG_UST_BUILD_WITH_LIBDL
-hello_LDADD += -ldl
-endif
-if LTTNG_UST_BUILD_WITH_LIBC_DL
-hello_LDADD += -lc
-endif
-
-noinst_SCRIPTS = run
-EXTRA_DIST = run
+EXTRA_DIST = README
This page took 0.023291 seconds and 4 git commands to generate.