Fix: Don't override user variables within the build system
[lttng-ust.git] / tests / hello / Makefile.am
index 847e64d907200685a2f3a8c41560bf19f835bbce..cb4d46266646fd57fd79a2806c4bc755e1593ffa 100644 (file)
@@ -1,8 +1,9 @@
-AM_CPPFLAGS = -I$(top_srcdir)/include -Wsystem-headers
+AM_CPPFLAGS = -I$(top_srcdir)/include -I$(top_builddir)/include -Wsystem-headers
 
 noinst_PROGRAMS = hello
 hello_SOURCES = hello.c tp.c ust_tests_hello.h
 hello_LDADD = $(top_builddir)/liblttng-ust/liblttng-ust.la
+hello_CFLAGS = -Werror=old-style-definition $(AM_CFLAGS)
 
 if LTTNG_UST_BUILD_WITH_LIBDL
 hello_LDADD += -ldl
@@ -10,6 +11,3 @@ endif
 if LTTNG_UST_BUILD_WITH_LIBC_DL
 hello_LDADD += -lc
 endif
-
-noinst_SCRIPTS = run
-EXTRA_DIST = run
This page took 0.022931 seconds and 4 git commands to generate.