Fix: Don't override user variables within the build system
[lttng-ust.git] / tests / hello / Makefile.am
index 8447e24a4909952e4f34fa282bce8ad6b56bdb93..cb4d46266646fd57fd79a2806c4bc755e1593ffa 100644 (file)
@@ -1,8 +1,13 @@
-AM_CPPFLAGS = -I$(top_srcdir)/include -I$(top_srcdir)/libust
+AM_CPPFLAGS = -I$(top_srcdir)/include -I$(top_builddir)/include -Wsystem-headers
 
 noinst_PROGRAMS = hello
-hello_SOURCES = hello.c tp.c tp.h
-hello_LDADD = $(top_builddir)/libust/libust.la
+hello_SOURCES = hello.c tp.c ust_tests_hello.h
+hello_LDADD = $(top_builddir)/liblttng-ust/liblttng-ust.la
+hello_CFLAGS = -Werror=old-style-definition $(AM_CFLAGS)
 
-noinst_SCRIPTS = run
-EXTRA_DIST = run
+if LTTNG_UST_BUILD_WITH_LIBDL
+hello_LDADD += -ldl
+endif
+if LTTNG_UST_BUILD_WITH_LIBC_DL
+hello_LDADD += -lc
+endif
This page took 0.023922 seconds and 4 git commands to generate.