Use a variable to select the dlopen lib in Makefiles
[lttng-ust.git] / tests / hello.cxx / Makefile.am
index f8a8f46df813afb8c07a45f9d7123af1f1ef7b11..4b0fb2344fc5107ab8584aa43ed8b2f8edac61fd 100644 (file)
@@ -2,11 +2,4 @@ AM_CPPFLAGS = -I$(top_srcdir)/include -I$(top_builddir)/include -Wsystem-headers
 
 noinst_PROGRAMS = hello
 hello_SOURCES = hello.cpp tp-cpp.cpp ust_tests_hello.h
-hello_LDADD = $(top_builddir)/liblttng-ust/liblttng-ust.la
-
-if LTTNG_UST_BUILD_WITH_LIBDL
-hello_LDADD += -ldl
-endif
-if LTTNG_UST_BUILD_WITH_LIBC_DL
-hello_LDADD += -lc
-endif
+hello_LDADD = $(top_builddir)/liblttng-ust/liblttng-ust.la $(DL_LIBS)
This page took 0.022855 seconds and 4 git commands to generate.