Use a variable to select the dlopen lib in Makefiles
[lttng-ust.git] / tests / hello.cxx / Makefile.am
index f56f431c70f9800c74ffa37b2d63dfd4a88e9f32..4b0fb2344fc5107ab8584aa43ed8b2f8edac61fd 100644 (file)
@@ -1,15 +1,5 @@
-AM_CPPFLAGS = -I$(top_srcdir)/include -Wsystem-headers
+AM_CPPFLAGS = -I$(top_srcdir)/include -I$(top_builddir)/include -Wsystem-headers
 
 noinst_PROGRAMS = hello
-hello_SOURCES = hello.cpp tp.c ust_tests_hello.h
-hello_LDADD = $(top_builddir)/liblttng-ust/liblttng-ust.la
-
-if LTTNG_UST_BUILD_WITH_LIBDL
-hello_LDADD += -ldl
-endif
-if LTTNG_UST_BUILD_WITH_LIBC_DL
-hello_LDADD += -lc
-endif
-
-noinst_SCRIPTS = run
-EXTRA_DIST = run
+hello_SOURCES = hello.cpp tp-cpp.cpp ust_tests_hello.h
+hello_LDADD = $(top_builddir)/liblttng-ust/liblttng-ust.la $(DL_LIBS)
This page took 0.023166 seconds and 4 git commands to generate.