Revert "Detect and document dependency on -ldl on Linux, -lc on BSD for dlopen"
[lttng-ust.git] / tests / dlopen / Makefile.am
index de05346c710b37251d2861946f169d8c4d4b6d79..89fd9dbfc57b993a16d700654b4cd429cbb76247 100644 (file)
@@ -6,14 +6,7 @@ libdummy_la_SOURCES = libdummy.c
 libdummy_la_LIBADD = $(top_builddir)/libust/libust.la $(top_builddir)/libust-initializer.o
 libdummy_la_LDFLAGS = -rpath /nowhere
 dlopen_SOURCES = dlopen.c
-dlopen_LDADD = $(top_builddir)/libust/libust.la $(top_builddir)/libust-initializer.o
-
-if LTTNG_UST_BUILD_WITH_LIBDL
-dlopen_LDADD += -ldl
-endif
-if LTTNG_UST_BUILD_WITH_LIBC_DL
-dlopen_LDADD += -lc
-endif
+dlopen_LDADD = -ldl $(top_builddir)/libust/libust.la $(top_builddir)/libust-initializer.o
 
 noinst_SCRIPTS = run
 EXTRA_DIST = run
This page took 0.025304 seconds and 4 git commands to generate.