Detect and document dependency on -ldl on Linux, -lc on BSD for dlopen
[lttng-ust.git] / tests / demo / Makefile.am
index 4afeaad79529bc4fad86eb377a70bdec5c0a04b7..4e113edc87705e0c9654d68b5b589df5e493533e 100644 (file)
@@ -37,5 +37,11 @@ liblttng_ust_provider_ust_tests_demo3_la_LDFLAGS = \
 
 noinst_PROGRAMS = demo
 demo_SOURCES = demo.c ust_tests_demo.h
-# The demo program only depends on libdl.
-demo_LDFLAGS = -ldl
+# The demo program only depends on libdl/libc for dlopen().
+if LTTNG_UST_BUILD_WITH_LIBDL
+demo_LDADD = -ldl
+endif
+if LTTNG_UST_BUILD_WITH_LIBC_DL
+demo_LDADD = -lc
+endif
+
This page took 0.023355 seconds and 4 git commands to generate.