Use a variable to select the dlopen lib in Makefiles
[lttng-ust.git] / tests / ctf-types / Makefile.am
index a9b40b6ac25a8cee36de141c4cf206c423aaac54..42d803f2a409ce6cb3fc7c63ce7703c9e0e2b7b4 100644 (file)
@@ -2,12 +2,5 @@ AM_CPPFLAGS = -I$(top_srcdir)/include -I$(top_builddir)/include -Wsystem-headers
 
 noinst_PROGRAMS = ctf-types
 ctf_types_SOURCES = ctf-types.c tp.c ust_tests_ctf_types.h
-ctf_types_LDADD = $(top_builddir)/liblttng-ust/liblttng-ust.la
+ctf_types_LDADD = $(top_builddir)/liblttng-ust/liblttng-ust.la $(DL_LIBS)
 ctf_types_CFLAGS = -Werror=old-style-definition $(AM_CFLAGS)
-
-if LTTNG_UST_BUILD_WITH_LIBDL
-ctf_types_LDADD += -ldl
-endif
-if LTTNG_UST_BUILD_WITH_LIBC_DL
-ctf_types_LDADD += -lc
-endif
This page took 0.022821 seconds and 4 git commands to generate.