tests: hello-many
[lttng-ust.git] / tests / Makefile.am
index 1da989f683711cdebc5f13e2212a172ee067ba55..c8505eb5ff77da7aec5ee633125c575abd09ef14 100644 (file)
@@ -1 +1,24 @@
-SUBDIRS = hello hello2 basic basic_long fork
+SUBDIRS = utils hello same_line_tracepoint snprintf benchmark ust-elf \
+               ctf-types test-app-ctx gcc-weak-hidden hello-many
+
+if CXX_WORKS
+SUBDIRS += hello.cxx
+endif
+
+LOG_DRIVER_FLAGS='--merge'
+LOG_DRIVER = env AM_TAP_AWK='$(AWK)' $(SHELL) \
+       $(top_srcdir)/config/tap-driver.sh
+
+TESTS = snprintf/test_snprintf \
+       ust-elf/test_ust_elf \
+       gcc-weak-hidden/test_gcc_weak_hidden
+
+check-loop:
+       while [ 0 ]; do \
+               $(MAKE) $(AM_MAKEFLAGS) check; \
+               if [ "$$?" != "0" ]; then \
+                       break; \
+               fi \
+       done
+
+.PHONY: check-loop
This page took 0.022866 seconds and 4 git commands to generate.