Add missing files to distribution
[lttng-ust.git] / tests / Makefile.am
index eca4e20abd42e222c02a5d3f75c34fb622896b71..b1042dbef1e64c7b0307a2b528a751792e962c9c 100644 (file)
@@ -1,3 +1,26 @@
-SUBDIRS = hello hello2 basic basic_long fork simple_include snprintf test-nevents
+SUBDIRS = utils hello same_line_tracepoint snprintf benchmark ust-elf \
+               ctf-types test-app-ctx gcc-weak-hidden hello-many
 
-noinst_SCRIPTS = test_loop runtests trace_matches
+if CXX_WORKS
+SUBDIRS += hello.cxx
+endif
+
+LOG_DRIVER_FLAGS='--merge'
+LOG_DRIVER = env AM_TAP_AWK='$(AWK)' $(SHELL) \
+       $(top_srcdir)/config/tap-driver.sh
+
+TESTS = snprintf/test_snprintf \
+       ust-elf/test_ust_elf \
+       gcc-weak-hidden/test_gcc_weak_hidden
+
+EXTRA_DIST = README
+
+check-loop:
+       while [ 0 ]; do \
+               $(MAKE) $(AM_MAKEFLAGS) check; \
+               if [ "$$?" != "0" ]; then \
+                       break; \
+               fi \
+       done
+
+.PHONY: check-loop
This page took 0.02585 seconds and 4 git commands to generate.