Tests: Replace prove by autotools tap runner
[lttng-ust.git] / tests / Makefile.am
index 377acd676aeb7a46b4db32a6f793e24d831ca881..96a3faae6b69427527a87b52bdb70c4cbf0af206 100644 (file)
@@ -5,23 +5,18 @@ if CXX_WORKS
 SUBDIRS += hello.cxx
 endif
 
-SCRIPT_LIST = test_loop run.sh unit_tests
+LOG_DRIVER = env AM_TAP_AWK='$(AWK)' $(SHELL) \
+       $(top_srcdir)/config/tap-driver.sh
 
-dist_noinst_SCRIPTS = $(SCRIPT_LIST)
+TESTS = snprintf/test_snprintf \
+       ust-elf/test_ust_elf
 
-all-local:
-       @if [ x"$(srcdir)" != x"$(builddir)" ]; then \
-               for script in $(SCRIPT_LIST); do \
-                       cp -f $(srcdir)/$$script $(builddir); \
-               done; \
-       fi
+check-loop:
+       while [ 0 ]; do \
+               $(MAKE) $(AM_MAKEFLAGS) check; \
+               if [ "$$?" != "0" ]; then \
+                       break; \
+               fi \
+       done
 
-clean-local:
-       @if [ x"$(srcdir)" != x"$(builddir)" ]; then \
-               for script in $(SCRIPT_LIST); do \
-                       rm -f $(builddir)/$$script; \
-               done; \
-       fi
-
-check-am:
-       ./run.sh unit_tests
+.PHONY: check-loop
This page took 0.023487 seconds and 4 git commands to generate.