Fix: sync event enablers before choosing header type
[lttng-ust.git] / tests / Makefile.am
index ab13cd73bb1b30c8cd1c51c777e915afd2d473ad..935c7546bbb94c2b62eefbf0b4006d321abf8fc8 100644 (file)
@@ -1,3 +1,24 @@
-SUBDIRS = hello hello2 basic basic_long fork simple_include snprintf test-nevents test-libustinstr-malloc dlopen same_line_marker trace_event
+SUBDIRS = utils hello same_line_tracepoint snprintf benchmark ust-elf \
+               ctf-types test-app-ctx gcc-weak-hidden
 
-dist_noinst_SCRIPTS = test_loop runtests trace_matches
+if CXX_WORKS
+SUBDIRS += hello.cxx
+endif
+
+LOG_DRIVER_FLAGS='--merge'
+LOG_DRIVER = env AM_TAP_AWK='$(AWK)' $(SHELL) \
+       $(top_srcdir)/config/tap-driver.sh
+
+TESTS = snprintf/test_snprintf \
+       ust-elf/test_ust_elf \
+       gcc-weak-hidden/test_gcc_weak_hidden
+
+check-loop:
+       while [ 0 ]; do \
+               $(MAKE) $(AM_MAKEFLAGS) check; \
+               if [ "$$?" != "0" ]; then \
+                       break; \
+               fi \
+       done
+
+.PHONY: check-loop
This page took 0.023153 seconds and 4 git commands to generate.