Fix: don't build C++ example if a C++ compiler isn't available
[lttng-ust.git] / tests / Makefile.am
index 2b124228e2990484f3f35766139a366a0be6f12a..7365ce47335ac608eea27d57c4e819b155ed7945 100644 (file)
@@ -1,7 +1,11 @@
 SUBDIRS = . hello hello-static-lib fork ust-basic-tracing ust-multi-test \
-               demo hello.cxx daemon
+               demo daemon
 #SUBDIRS = . hello2 basic basic_long simple_include snprintf test-nevents test-libustinstr-malloc dlopen same_line_marker trace_event register_test tracepoint libustctl_function_tests exit-fast
 
+if CXX_WORKS
+SUBDIRS += hello.cxx
+endif
+
 dist_noinst_SCRIPTS = test_loop runtests trace_matches
 
 noinst_LIBRARIES = libtap.a
This page took 0.022746 seconds and 4 git commands to generate.