Move "hello-static-lib" to doc/examples and add non-automake Makefiles
[lttng-ust.git] / tests / Makefile.am
index e79ab7cec1760c256a1b25589ca8037f217608da..317edcb0b355e87bf51947ec2e8b4ea572a48b0b 100644 (file)
@@ -1,11 +1,14 @@
-SUBDIRS = . hello hello-static-lib fork ust-basic-tracing ust-multi-test demo hello.cxx
-#SUBDIRS = . hello2 basic basic_long simple_include snprintf test-nevents test-libustinstr-malloc dlopen same_line_marker trace_event register_test tracepoint libustctl_function_tests exit-fast
+SUBDIRS = . hello same_line_tracepoint snprintf
 
-dist_noinst_SCRIPTS = test_loop runtests trace_matches
+if CXX_WORKS
+SUBDIRS += hello.cxx
+endif
+
+dist_noinst_SCRIPTS = test_loop run.sh trace_matches unit_tests
 
 noinst_LIBRARIES = libtap.a
 
-libtap_a_SOURCES = \
-       tap.c \
-       tap.h
+libtap_a_SOURCES = tap.c tap.h
 
+check-am:
+       ./run.sh unit_tests
This page took 0.024169 seconds and 4 git commands to generate.