Move "hello-static-lib" to doc/examples and add non-automake Makefiles
[lttng-ust.git] / tests / Makefile.am
index c1fc928b7a13d460d8ea837b0e3598e63ebf0cde..317edcb0b355e87bf51947ec2e8b4ea572a48b0b 100644 (file)
@@ -1,3 +1,14 @@
-SUBDIRS = hello hello2 basic basic_long fork simple_include snprintf test-nevents test-libustinstr-malloc dlopen same_line_marker
+SUBDIRS = . hello same_line_tracepoint snprintf
 
-dist_noinst_SCRIPTS = test_loop runtests trace_matches
+if CXX_WORKS
+SUBDIRS += hello.cxx
+endif
+
+dist_noinst_SCRIPTS = test_loop run.sh trace_matches unit_tests
+
+noinst_LIBRARIES = libtap.a
+
+libtap_a_SOURCES = tap.c tap.h
+
+check-am:
+       ./run.sh unit_tests
This page took 0.022801 seconds and 4 git commands to generate.