Move "hello-static-lib" to doc/examples and add non-automake Makefiles
[lttng-ust.git] / tests / Makefile.am
index 9eee9d9c278c60f9d934612085dcf636e15ca553..317edcb0b355e87bf51947ec2e8b4ea572a48b0b 100644 (file)
@@ -1,16 +1,14 @@
-SUBDIRS = . hello hello-static-lib fork demo daemon
-#ust-basic-tracing ust-multi-test
-#SUBDIRS = . hello2 basic basic_long simple_include snprintf test-nevents test-libustinstr-malloc dlopen same_line_marker trace_event register_test tracepoint libustctl_function_tests exit-fast
+SUBDIRS = . hello same_line_tracepoint snprintf
 
 if CXX_WORKS
 SUBDIRS += hello.cxx
 endif
 
-dist_noinst_SCRIPTS = test_loop runtests trace_matches
+dist_noinst_SCRIPTS = test_loop run.sh trace_matches unit_tests
 
 noinst_LIBRARIES = libtap.a
 
-libtap_a_SOURCES = \
-       tap.c \
-       tap.h
+libtap_a_SOURCES = tap.c tap.h
 
+check-am:
+       ./run.sh unit_tests
This page took 0.022997 seconds and 4 git commands to generate.