Move "hello-static-lib" to doc/examples and add non-automake Makefiles
[lttng-ust.git] / tests / Makefile.am
index 83119805714186dbbe8982a371987c2a5f5fb485..317edcb0b355e87bf51947ec2e8b4ea572a48b0b 100644 (file)
@@ -1,10 +1,14 @@
-SUBDIRS = . hello hello2 basic basic_long fork simple_include snprintf test-nevents test-libustinstr-malloc dlopen same_line_marker trace_event register_test tracepoint libustctl_function_tests exit-fast
+SUBDIRS = . hello same_line_tracepoint snprintf
 
-dist_noinst_SCRIPTS = test_loop runtests trace_matches
+if CXX_WORKS
+SUBDIRS += hello.cxx
+endif
+
+dist_noinst_SCRIPTS = test_loop run.sh trace_matches unit_tests
 
 noinst_LIBRARIES = libtap.a
 
-libtap_a_SOURCES = \
-       tap.c \
-       tap.h
+libtap_a_SOURCES = tap.c tap.h
 
+check-am:
+       ./run.sh unit_tests
This page took 0.022953 seconds and 4 git commands to generate.