Refactor liblttng-ust-jul in liblttng-ust-agent
[lttng-ust.git] / tests / Makefile.am
index e4e06cebb8fd985aa41aa98e86a95409e8205c42..30b0e9a0f23897d6588bf37d8059c84c9004958a 100644 (file)
@@ -1,14 +1,26 @@
-SUBDIRS = . hello hello2 basic basic_long fork simple_include snprintf test-nevents test-libustinstr-malloc dlopen same_line_marker trace_event register_test tracepoint libustctl_function_tests
+SUBDIRS = utils hello same_line_tracepoint snprintf benchmark
 
-dist_noinst_SCRIPTS = test_loop runtests trace_matches
+if CXX_WORKS
+SUBDIRS += hello.cxx
+endif
 
-lib_LTLIBRARIES = libtap.la
+SCRIPT_LIST = test_loop run.sh unit_tests
 
-libtap_la_SOURCES = \
-       tap.c \
-       tap.h
+dist_noinst_SCRIPTS = $(SCRIPT_LIST)
 
-libtap_la_LDFLAGS = -no-undefined -version-info 0:0:0
+all-local:
+       @if [ x"$(srcdir)" != x"$(builddir)" ]; then \
+               for script in $(SCRIPT_LIST); do \
+                       cp -f $(srcdir)/$$script $(builddir); \
+               done; \
+       fi
 
-libtap_la_LIBADD = \
-       -lpthread
\ No newline at end of file
+clean-local:
+       @if [ x"$(srcdir)" != x"$(builddir)" ]; then \
+               for script in $(SCRIPT_LIST); do \
+                       rm -f $(builddir)/$$script; \
+               done; \
+       fi
+
+check-am:
+       ./run.sh unit_tests
This page took 0.022659 seconds and 4 git commands to generate.