Refactor liblttng-ust-jul in liblttng-ust-agent
[lttng-ust.git] / tests / Makefile.am
index a9ba3262b092cf8c6b5ae3c6e46f3419edfca552..30b0e9a0f23897d6588bf37d8059c84c9004958a 100644 (file)
@@ -1,11 +1,26 @@
-SUBDIRS = . hello fork
-#SUBDIRS = . hello2 basic basic_long simple_include snprintf test-nevents test-libustinstr-malloc dlopen same_line_marker trace_event register_test tracepoint libustctl_function_tests exit-fast
+SUBDIRS = utils hello same_line_tracepoint snprintf benchmark
 
-dist_noinst_SCRIPTS = test_loop runtests trace_matches
+if CXX_WORKS
+SUBDIRS += hello.cxx
+endif
 
-noinst_LIBRARIES = libtap.a
+SCRIPT_LIST = test_loop run.sh unit_tests
 
-libtap_a_SOURCES = \
-       tap.c \
-       tap.h
+dist_noinst_SCRIPTS = $(SCRIPT_LIST)
 
+all-local:
+       @if [ x"$(srcdir)" != x"$(builddir)" ]; then \
+               for script in $(SCRIPT_LIST); do \
+                       cp -f $(srcdir)/$$script $(builddir); \
+               done; \
+       fi
+
+clean-local:
+       @if [ x"$(srcdir)" != x"$(builddir)" ]; then \
+               for script in $(SCRIPT_LIST); do \
+                       rm -f $(builddir)/$$script; \
+               done; \
+       fi
+
+check-am:
+       ./run.sh unit_tests
This page took 0.022797 seconds and 4 git commands to generate.