Refactor liblttng-ust-jul in liblttng-ust-agent
[lttng-ust.git] / tests / Makefile.am
index 1da989f683711cdebc5f13e2212a172ee067ba55..30b0e9a0f23897d6588bf37d8059c84c9004958a 100644 (file)
@@ -1 +1,26 @@
-SUBDIRS = hello hello2 basic basic_long fork
+SUBDIRS = utils hello same_line_tracepoint snprintf benchmark
+
+if CXX_WORKS
+SUBDIRS += hello.cxx
+endif
+
+SCRIPT_LIST = test_loop run.sh unit_tests
+
+dist_noinst_SCRIPTS = $(SCRIPT_LIST)
+
+all-local:
+       @if [ x"$(srcdir)" != x"$(builddir)" ]; then \
+               for script in $(SCRIPT_LIST); do \
+                       cp -f $(srcdir)/$$script $(builddir); \
+               done; \
+       fi
+
+clean-local:
+       @if [ x"$(srcdir)" != x"$(builddir)" ]; then \
+               for script in $(SCRIPT_LIST); do \
+                       rm -f $(builddir)/$$script; \
+               done; \
+       fi
+
+check-am:
+       ./run.sh unit_tests
This page took 0.023846 seconds and 4 git commands to generate.