Move lttng_ust_enum_get_from_desc to libcommon
[lttng-ust.git] / src / common / Makefile.am
index e75ee2509e44c0c657bcc373016a18f61849051b..ce427655fc82dc003cc3daed3ce33a7a22f0ed97 100644 (file)
@@ -11,13 +11,19 @@ noinst_HEADERS = \
        bitfield.h \
        bitmap.h \
        clock.h \
+       creds.h \
        dynamic-type.h \
-       elf.h \
+       err-ptr.h \
+       events.h \
+       hash.h \
+       jhash.h \
        logging.h \
        macros.h \
+       ns.h \
        patient.h \
        procname.h \
        safe-snprintf.h \
+       tracepoint.h \
        wait.h
 
 noinst_HEADERS += \
@@ -44,6 +50,7 @@ noinst_HEADERS += \
 
 noinst_LTLIBRARIES = \
        libcounter.la \
+       libcompat.la \
        libmsgpack.la \
        libringbuffer.la \
        libsnprintf.la \
@@ -61,9 +68,7 @@ libcounter_la_SOURCES = \
        counter/shm.c \
        counter/shm.h \
        counter/shm_internal.h \
-       counter/shm_types.h \
-       counter/smp.c \
-       counter/smp.h
+       counter/shm_types.h
 
 libcounter_la_LIBADD = -lrt
 
@@ -73,6 +78,11 @@ endif
 
 libcounter_la_CFLAGS = -DUST_COMPONENT="libcounter" $(AM_CFLAGS)
 
+# compat
+libcompat_la_SOURCES = \
+       compat/futex.c \
+       compat/futex.h
+
 # msgpack
 libmsgpack_la_SOURCES = \
        msgpack/msgpack.c \
@@ -99,8 +109,6 @@ libringbuffer_la_SOURCES = \
        ringbuffer/shm.h \
        ringbuffer/shm_internal.h \
        ringbuffer/shm_types.h \
-       ringbuffer/smp.c \
-       ringbuffer/smp.h \
        ringbuffer/vatomic.h
 
 libringbuffer_la_LIBADD = \
@@ -129,13 +137,23 @@ libsnprintf_la_SOURCES = \
 
 # Common library
 libcommon_la_SOURCES = \
+       elf.c \
+       elf.h \
+       events.c \
        getenv.c \
        getenv.h \
        logging.c \
        logging.h \
+       smp.c \
+       smp.h \
+       strutils.c \
+       strutils.h \
+       utils.c \
+       utils.h \
        patient.c
 
 libcommon_la_LIBADD = \
+       libcompat.la \
        libmsgpack.la \
        libsnprintf.la
 
This page took 0.023547 seconds and 4 git commands to generate.