Move futex wrapper to 'common/compat/'
[lttng-ust.git] / src / common / Makefile.am
index e450f8c858876fd617b6344ab122626d7c75e821..b847001e41b72a307b00ce7edaa7ef5406246dc6 100644 (file)
@@ -45,6 +45,7 @@ noinst_HEADERS += \
 
 noinst_LTLIBRARIES = \
        libcounter.la \
+       libcompat.la \
        libmsgpack.la \
        libringbuffer.la \
        libsnprintf.la \
@@ -74,6 +75,11 @@ endif
 
 libcounter_la_CFLAGS = -DUST_COMPONENT="libcounter" $(AM_CFLAGS)
 
+# compat
+libcompat_la_SOURCES = \
+       compat/futex.c \
+       compat/futex.h
+
 # msgpack
 libmsgpack_la_SOURCES = \
        msgpack/msgpack.c \
@@ -137,6 +143,7 @@ libcommon_la_SOURCES = \
        patient.c
 
 libcommon_la_LIBADD = \
+       libcompat.la \
        libmsgpack.la \
        libsnprintf.la
 
This page took 0.023613 seconds and 4 git commands to generate.