ust-fd: Add close_range declaration
[lttng-ust.git] / src / common / Makefile.am
index d80172dd0b9482d0a6689f17de5310afdf92fde2..ad889d165d784582d93aff771ae5a9ed2fdd7bbc 100644 (file)
@@ -1,3 +1,5 @@
+# SPDX-FileCopyrightText: 2023 EfficiOS, Inc
+#
 # SPDX-License-Identifier: LGPL-2.1-only
 
 AUTOMAKE_OPTIONS = subdir-objects
@@ -12,14 +14,19 @@ noinst_HEADERS = \
        bitmap.h \
        clock.h \
        creds.h \
-       dynamic-type.h \
-       elf.h \
+       err-ptr.h \
        events.h \
+       getcpu.h \
+       hash.h \
+       jhash.h \
        logging.h \
        macros.h \
+       ns.h \
        patient.h \
        procname.h \
        safe-snprintf.h \
+       tracepoint.h \
+       tracer.h \
        wait.h
 
 noinst_HEADERS += \
@@ -46,9 +53,10 @@ noinst_HEADERS += \
 
 noinst_LTLIBRARIES = \
        libcounter.la \
-       libcompat.la \
+       libcounter-clients.la \
        libmsgpack.la \
        libringbuffer.la \
+       libringbuffer-clients.la \
        libsnprintf.la \
        libcommon.la \
        libustcomm.la
@@ -64,9 +72,7 @@ libcounter_la_SOURCES = \
        counter/shm.c \
        counter/shm.h \
        counter/shm_internal.h \
-       counter/shm_types.h \
-       counter/smp.c \
-       counter/smp.h
+       counter/shm_types.h
 
 libcounter_la_LIBADD = -lrt
 
@@ -76,10 +82,14 @@ endif
 
 libcounter_la_CFLAGS = -DUST_COMPONENT="libcounter" $(AM_CFLAGS)
 
-# compat
-libcompat_la_SOURCES = \
-       compat/futex.c \
-       compat/futex.h
+# counter-clients
+libcounter_clients_la_SOURCES = \
+       counter-clients/clients.c \
+       counter-clients/clients.h \
+       counter-clients/percpu-32-modular.c \
+       counter-clients/percpu-64-modular.c
+
+libcounter_clients_la_CFLAGS = -DUST_COMPONENT="libcounter-clients" $(AM_CFLAGS)
 
 # msgpack
 libmsgpack_la_SOURCES = \
@@ -107,8 +117,6 @@ libringbuffer_la_SOURCES = \
        ringbuffer/shm.h \
        ringbuffer/shm_internal.h \
        ringbuffer/shm_types.h \
-       ringbuffer/smp.c \
-       ringbuffer/smp.h \
        ringbuffer/vatomic.h
 
 libringbuffer_la_LIBADD = \
@@ -120,6 +128,20 @@ endif
 
 libringbuffer_la_CFLAGS = -DUST_COMPONENT="libringbuffer" $(AM_CFLAGS)
 
+# ringbuffer-client
+libringbuffer_clients_la_SOURCES = \
+       ringbuffer-clients/clients.c \
+       ringbuffer-clients/clients.h \
+       ringbuffer-clients/discard.c \
+       ringbuffer-clients/discard-rt.c \
+       ringbuffer-clients/metadata.c \
+       ringbuffer-clients/metadata-template.h \
+       ringbuffer-clients/overwrite.c \
+       ringbuffer-clients/overwrite-rt.c \
+       ringbuffer-clients/template.h
+
+libringbuffer_clients_la_CFLAGS = -DUST_COMPONENT="libringbuffer-clients" $(AM_CFLAGS)
+
 # snprintf
 libsnprintf_la_SOURCES = \
        snprintf/fflush.c \
@@ -137,14 +159,27 @@ libsnprintf_la_SOURCES = \
 
 # Common library
 libcommon_la_SOURCES = \
+       core.c \
+       dynamic-type.c \
+       dynamic-type.h \
+       elf.c \
+       elf.h \
+       events.c \
        getenv.c \
        getenv.h \
        logging.c \
        logging.h \
+       smp.c \
+       smp.h \
+       populate.c \
+       populate.h \
+       strutils.c \
+       strutils.h \
+       utils.c \
+       utils.h \
        patient.c
 
 libcommon_la_LIBADD = \
-       libcompat.la \
        libmsgpack.la \
        libsnprintf.la
 
@@ -152,4 +187,4 @@ libustcomm_la_SOURCES = \
        ustcomm.c \
        ustcomm.h
 
-EXTRA_DIST = snprintf/README
+EXTRA_DIST = snprintf/README.md
This page took 0.023941 seconds and 4 git commands to generate.