Add missing files to distribution
[lttng-ust.git] / snprintf / Makefile.am
index 04148b71aeece6b46b0d1a4312d86ee894567710..59b0272325adeefd6ed6c9d4bff8e15bb39fed4b 100644 (file)
@@ -1,6 +1,7 @@
 AM_CPPFLAGS = -I$(top_srcdir)/include -I$(top_srcdir)/libustcomm
+AM_CFLAGS += -fno-strict-aliasing
 
-lib_LTLIBRARIES = libustsnprintf.la
+noinst_LTLIBRARIES = libustsnprintf.la
 libustsnprintf_la_SOURCES = \
        fflush.c \
        fileext.h \
@@ -13,11 +14,11 @@ libustsnprintf_la_SOURCES = \
        various.h \
        vfprintf.c \
        wcio.h \
-       wsetup.c
-libustsnprintf_la_LDFLAGS = -no-undefined -version-info 0:0:0 -static
-libustsnprintf_la_CFLAGS = -DUST_COMPONENT="ust_snprintf" -fPIC
+       wsetup.c \
+       core.c \
+       patient_write.c
 
-check_PROGRAMS = prog
-prog_SOURCES = prog.c
-prog_LDADD = libustsnprintf.la
-TESTS = prog
+libustsnprintf_la_LDFLAGS = -no-undefined -static
+libustsnprintf_la_CFLAGS = -DUST_COMPONENT="lttng_ust_snprintf" -fPIC $(AM_CFLAGS)
+
+EXTRA_DIST = README
This page took 0.023445 seconds and 4 git commands to generate.