Add UST_DEBUG env. var. support
[lttng-ust.git] / libust / Makefile.am
index e38956a9f4bd60f66838286964691cade7e5c4a5..0fa4a2b56a83f24e940cbc2c2e004c29be49ca7c 100644 (file)
@@ -1,24 +1,33 @@
-AM_CPPFLAGS = -I$(top_srcdir)/include -I$(top_srcdir)/libustcomm
+AM_CPPFLAGS = -I$(top_srcdir)/include
+AM_CFLAGS = -fno-strict-aliasing
 
 lib_LTLIBRARIES = libust.la
+
 libust_la_SOURCES = \
-       marker.c \
        tracepoint.c \
-       channels.c \
-       channels.h \
-       marker-control.c \
-       marker-control.h \
-       buffers.c \
-       buffers.h \
-       tracer.c \
-       tracer.h \
-       tracercore.c \
-       tracercore.h \
-       serialize.c \
-       tracectl.c \
-       $(top_builddir)/libustcomm/ustcomm.c \
-       tracerconst.h \
-       header-inline.h
+       ltt-tracer.h \
+       ltt-tracer-core.h \
+       ltt-ring-buffer-client.h \
+       ltt-ring-buffer-client-discard.c \
+       ltt-ring-buffer-client-overwrite.c \
+       ltt-ring-buffer-metadata-client.h \
+       ltt-ring-buffer-metadata-client.c \
+       ltt-events.c \
+       ltt-context.c \
+       ltt-probes.c \
+       lttng-ust-abi.c \
+       lttng-ust-comm.c \
+       ust-core.c
+
+#removed: buffers.c buffers.h
+
 libust_la_LDFLAGS = -no-undefined -version-info 0:0:0
-libust_la_LIBADD = -lpthread $(top_builddir)/snprintf/libustsnprintf.la
-libust_la_CFLAGS = -DUST_COMPONENT="libust"
+
+libust_la_LIBADD = \
+       -lpthread \
+       -lrt \
+       -luuid \
+       $(top_builddir)/snprintf/libustsnprintf.la \
+       $(top_builddir)/libringbuffer/libringbuffer.la
+
+libust_la_CFLAGS = -DUST_COMPONENT="libust" -fno-strict-aliasing
This page took 0.023308 seconds and 4 git commands to generate.