Add UST_DEBUG env. var. support
[lttng-ust.git] / libust / Makefile.am
index 7e5a0df98defbb0db401a933d187e7b0c0ad0b6a..0fa4a2b56a83f24e940cbc2c2e004c29be49ca7c 100644 (file)
@@ -5,7 +5,6 @@ lib_LTLIBRARIES = libust.la
 
 libust_la_SOURCES = \
        tracepoint.c \
-       trace_event.c \
        ltt-tracer.h \
        ltt-tracer-core.h \
        ltt-ring-buffer-client.h \
@@ -14,7 +13,11 @@ libust_la_SOURCES = \
        ltt-ring-buffer-metadata-client.h \
        ltt-ring-buffer-metadata-client.c \
        ltt-events.c \
-       lttng-ust-abi.c
+       ltt-context.c \
+       ltt-probes.c \
+       lttng-ust-abi.c \
+       lttng-ust-comm.c \
+       ust-core.c
 
 #removed: buffers.c buffers.h
 
@@ -23,6 +26,8 @@ libust_la_LDFLAGS = -no-undefined -version-info 0:0:0
 libust_la_LIBADD = \
        -lpthread \
        -lrt \
-       $(top_builddir)/snprintf/libustsnprintf.la
+       -luuid \
+       $(top_builddir)/snprintf/libustsnprintf.la \
+       $(top_builddir)/libringbuffer/libringbuffer.la
 
 libust_la_CFLAGS = -DUST_COMPONENT="libust" -fno-strict-aliasing
This page took 0.024333 seconds and 4 git commands to generate.