Fix: Don't override user variables within the build system
[lttng-ust.git] / libringbuffer / Makefile.am
index b5b0ebd1f2e7cda10a6cc6dc17d7ff1c610c9c2e..dce5b988641cb0f32b80c02084dbbdcf557d79b6 100644 (file)
@@ -1,5 +1,5 @@
-AM_CPPFLAGS = -I$(top_srcdir)/include
-AM_CFLAGS = -fno-strict-aliasing
+AM_CPPFLAGS = -I$(top_srcdir)/include -I$(top_builddir)/include
+AM_CFLAGS += -fno-strict-aliasing
 
 noinst_LTLIBRARIES = libringbuffer.la
 
@@ -12,9 +12,9 @@ libringbuffer_la_SOURCES = \
        backend.h backend_internal.h backend_types.h \
        frontend_api.h frontend.h frontend_internal.h frontend_types.h \
        nohz.h vatomic.h tlsfixup.h
-       
+
 libringbuffer_la_LIBADD = \
        -lpthread \
        -lrt
 
-libringbuffer_la_CFLAGS = -DUST_COMPONENT="libringbuffer" -fno-strict-aliasing
+libringbuffer_la_CFLAGS = -DUST_COMPONENT="libringbuffer" $(AM_CFLAGS)
This page took 0.022855 seconds and 4 git commands to generate.