Fix: race between lttng-ust getenv() and application setenv()
[lttng-ust.git] / liblttng-ust / Makefile.am
index 796ce5b3837fe939cb3599d50275d8eadb195a7e..eea99572fb0276d8880a99f2149fdb9993f29950 100644 (file)
@@ -7,12 +7,14 @@ lib_LTLIBRARIES = liblttng-ust-tracepoint.la liblttng-ust.la
 
 liblttng_ust_tracepoint_la_SOURCES = \
        tracepoint.c \
+       tracepoint-weak-test.c \
        tracepoint-internal.h \
        lttng-tracer-core.h \
        jhash.h \
        error.h
 liblttng_ust_tracepoint_la_LIBADD = \
        -lurcu-bp \
+       -lpthread \
        $(top_builddir)/snprintf/libustsnprintf.la
 liblttng_ust_tracepoint_la_LDFLAGS = -no-undefined -version-info $(LTTNG_UST_LIBRARY_VERSION)
 liblttng_ust_tracepoint_la_CFLAGS = -DUST_COMPONENT="liblttng_ust_tracepoint" -fno-strict-aliasing
@@ -21,11 +23,13 @@ liblttng_ust_runtime_la_SOURCES = \
        lttng-ust-comm.c \
        lttng-ust-abi.c \
        lttng-probes.c \
+       lttng-context-provider.c \
        lttng-context-vtid.c \
        lttng-context-vpid.c \
        lttng-context-pthread-id.c \
        lttng-context-procname.c \
        lttng-context-ip.c \
+       lttng-context-cpu-id.c \
        lttng-context.c \
        lttng-events.c \
        lttng-filter.c \
@@ -35,9 +39,12 @@ liblttng_ust_runtime_la_SOURCES = \
        lttng-filter-interpreter.c \
        filter-bytecode.h \
        lttng-hash-helper.h \
-       lttng-ust-baddr.c \
-       lttng-ust-baddr.h \
-       ust_baddr_statedump.h \
+       lttng-ust-elf.c \
+       lttng-ust-statedump.c \
+       lttng-ust-statedump.h \
+       lttng-ust-statedump-provider.h \
+       ust_lib.c \
+       ust_lib.h \
        tracepoint-internal.h \
        clock.h \
        compat.h \
@@ -46,17 +53,24 @@ liblttng_ust_runtime_la_SOURCES = \
        lttng-ust-uuid.h \
        error.h \
        tracef.c \
-       lttng-ust-tracef-provider.h
+       lttng-ust-tracef-provider.h \
+       tracelog.c \
+       lttng-ust-tracelog-provider.h \
+       getenv.h
 
 if HAVE_PERF_EVENT
 liblttng_ust_runtime_la_SOURCES += \
-       lttng-context-perf-counters.c
+       lttng-context-perf-counters.c \
+       perf_event.h
 endif
 
 liblttng_ust_support_la_SOURCES = \
        lttng-tracer.h \
        lttng-tracer-core.h \
        ust-core.c \
+       getenv.h \
+       getenv.c \
+       lttng-ust-dynamic-type.c \
        lttng-rb-clients.h \
        lttng-ring-buffer-client.h \
        lttng-ring-buffer-client-discard.c \
@@ -65,7 +79,7 @@ liblttng_ust_support_la_SOURCES = \
        lttng-ring-buffer-client-overwrite-rt.c \
        lttng-ring-buffer-metadata-client.h \
        lttng-ring-buffer-metadata-client.c \
-       lttng-clock.c
+       lttng-clock.c lttng-getcpu.c
 
 liblttng_ust_la_SOURCES =
 
This page took 0.023219 seconds and 4 git commands to generate.