Fix: race between lttng-ust getenv() and application setenv()
[lttng-ust.git] / liblttng-ust / Makefile.am
index 698b4805ee800d7fef8fbd117958b0830da57858..eea99572fb0276d8880a99f2149fdb9993f29950 100644 (file)
@@ -7,12 +7,14 @@ lib_LTLIBRARIES = liblttng-ust-tracepoint.la liblttng-ust.la
 
 liblttng_ust_tracepoint_la_SOURCES = \
        tracepoint.c \
+       tracepoint-weak-test.c \
        tracepoint-internal.h \
        lttng-tracer-core.h \
        jhash.h \
        error.h
 liblttng_ust_tracepoint_la_LIBADD = \
        -lurcu-bp \
+       -lpthread \
        $(top_builddir)/snprintf/libustsnprintf.la
 liblttng_ust_tracepoint_la_LDFLAGS = -no-undefined -version-info $(LTTNG_UST_LIBRARY_VERSION)
 liblttng_ust_tracepoint_la_CFLAGS = -DUST_COMPONENT="liblttng_ust_tracepoint" -fno-strict-aliasing
@@ -21,6 +23,7 @@ liblttng_ust_runtime_la_SOURCES = \
        lttng-ust-comm.c \
        lttng-ust-abi.c \
        lttng-probes.c \
+       lttng-context-provider.c \
        lttng-context-vtid.c \
        lttng-context-vpid.c \
        lttng-context-pthread-id.c \
@@ -40,6 +43,8 @@ liblttng_ust_runtime_la_SOURCES = \
        lttng-ust-statedump.c \
        lttng-ust-statedump.h \
        lttng-ust-statedump-provider.h \
+       ust_lib.c \
+       ust_lib.h \
        tracepoint-internal.h \
        clock.h \
        compat.h \
@@ -55,13 +60,17 @@ liblttng_ust_runtime_la_SOURCES = \
 
 if HAVE_PERF_EVENT
 liblttng_ust_runtime_la_SOURCES += \
-       lttng-context-perf-counters.c
+       lttng-context-perf-counters.c \
+       perf_event.h
 endif
 
 liblttng_ust_support_la_SOURCES = \
        lttng-tracer.h \
        lttng-tracer-core.h \
        ust-core.c \
+       getenv.h \
+       getenv.c \
+       lttng-ust-dynamic-type.c \
        lttng-rb-clients.h \
        lttng-ring-buffer-client.h \
        lttng-ring-buffer-client-discard.c \
This page took 0.023816 seconds and 4 git commands to generate.