Fix: add missing getenv wrapper
[lttng-ust.git] / liblttng-ust / Makefile.am
index cc105d7d319b975093bc3f0a784c487f511c77f8..10797d05ff1f22a35a8639c4fca14c96895381c9 100644 (file)
@@ -12,7 +12,8 @@ liblttng_ust_tracepoint_la_SOURCES = \
        jhash.h \
        error.h
 liblttng_ust_tracepoint_la_LIBADD = \
-       -lurcu-bp
+       -lurcu-bp \
+       $(top_builddir)/snprintf/libustsnprintf.la
 liblttng_ust_tracepoint_la_LDFLAGS = -no-undefined -version-info $(LTTNG_UST_LIBRARY_VERSION)
 liblttng_ust_tracepoint_la_CFLAGS = -DUST_COMPONENT="liblttng_ust_tracepoint" -fno-strict-aliasing
 
@@ -24,6 +25,7 @@ liblttng_ust_runtime_la_SOURCES = \
        lttng-context-vpid.c \
        lttng-context-pthread-id.c \
        lttng-context-procname.c \
+       lttng-context-ip.c \
        lttng-context.c \
        lttng-events.c \
        lttng-filter.c \
@@ -33,18 +35,30 @@ liblttng_ust_runtime_la_SOURCES = \
        lttng-filter-interpreter.c \
        filter-bytecode.h \
        lttng-hash-helper.h \
+       lttng-ust-baddr.c \
+       lttng-ust-baddr.h \
+       ust_baddr_statedump.h \
        tracepoint-internal.h \
        clock.h \
        compat.h \
        wait.h \
        jhash.h \
        lttng-ust-uuid.h \
-       error.h
+       error.h \
+       tracef.c \
+       lttng-ust-tracef-provider.h \
+       getenv.h
+
+if HAVE_PERF_EVENT
+liblttng_ust_runtime_la_SOURCES += \
+       lttng-context-perf-counters.c
+endif
 
 liblttng_ust_support_la_SOURCES = \
        lttng-tracer.h \
        lttng-tracer-core.h \
        ust-core.c \
+       lttng-rb-clients.h \
        lttng-ring-buffer-client.h \
        lttng-ring-buffer-client-discard.c \
        lttng-ring-buffer-client-discard-rt.c \
@@ -64,9 +78,10 @@ liblttng_ust_la_LIBADD = \
        -lpthread \
        -lrt \
        -lurcu-cds \
-       -llttng-ust-tracepoint \
+       -ldl \
        $(top_builddir)/snprintf/libustsnprintf.la \
        $(top_builddir)/liblttng-ust-comm/liblttng-ust-comm.la \
+       liblttng-ust-tracepoint.la \
        liblttng-ust-runtime.la liblttng-ust-support.la
 
 liblttng_ust_la_CFLAGS = -DUST_COMPONENT="liblttng_ust" -fno-strict-aliasing
This page took 0.023991 seconds and 4 git commands to generate.