Fix python agent build/install/uninstall with DESTDIR specified
[lttng-ust.git] / liblttng-ust-python-agent / Makefile.am
index f80b8a3f04a026cb7eba5ee2d2747c930477ab8a..e2a15f48da8898a1c5263737ef2b58ef5cf87598 100644 (file)
@@ -15,16 +15,16 @@ all-local:
        $(PYTHON) setup.py build --verbose
 
 install-exec-local:
-       if [ "$(DESTDIR)" = "" ]; then \
-               $(PYTHON) setup.py install --prefix=$(prefix) --record install_files.txt  --verbose --no-compile $(DISTSETUPOPTS);  \
-       else \
-               $(PYTHON) setup.py install --root=$(DESTDIR) --verbose install_files.txt  --prefix=$(prefix) --no-compile $(DISTSETUPOPTS); \
-       fi
+       @opts="--prefix=$(prefix) --verbose --no-compile $(DISTSETUPOPTS)"; \
+       if [ "$(DESTDIR)" != "" ]; then \
+               opts="$$opts --root=$(DESTDIR)"; \
+       fi; \
+       $(PYTHON) setup.py install $$opts;
+
 clean-local:
        rm -rf build
 
 uninstall-local:
-       cat install_files.txt | xargs rm -rf
        rm -rf $(DESTDIR)$(pkgpythondir)
 
 EXTRA_DIST=$(agent_path)
This page took 0.030782 seconds and 4 git commands to generate.