Use libtool syntax in LDADD
[lttng-ust.git] / liblttng-ust-python-agent / Makefile.am
index 7b5144708127fa5dad8518e0cd37d37730cc9760..077e50c5fb4d581eddf31151dd994161f6d9581a 100644 (file)
@@ -1,20 +1,10 @@
-
-AM_CPPFLAGS = $(PYTHON_INCLUDE) -I$(top_srcdir)/include/
-AM_CFLAGS = -fno-strict-aliasing
-
-EXTRA_DIST = lttng-agent.py.in
-
-lttng_agent_PYTHON = lttng_agent.py
-lttng_agentdir = $(pythondir)
+# tracepoint provider: always built/installed (does not depend on Python per se)
+AM_CPPFLAGS = -I$(top_srcdir)/include/ \
+       -I$(top_builddir)/include/
+AM_CFLAGS += -fno-strict-aliasing
 
 lib_LTLIBRARIES = liblttng-ust-python-agent.la
 
-nodist_liblttng_ust_python_agent_la_SOURCES = lttng_agent.py
 liblttng_ust_python_agent_la_SOURCES = lttng_ust_python.c lttng_ust_python.h
-liblttng_ust_python_agent_la_LIBADD = -lc -llttng-ust \
-               -L$(top_builddir)/liblttng-ust/.libs
-
-all:
-       $(SED) 's|LIBDIR_STR|$(libdir)|g' < lttng_agent.py.in > lttng_agent.py
-
-CLEANFILES = lttng_agent.py
+liblttng_ust_python_agent_la_LIBADD = -lc \
+       $(top_builddir)/liblttng-ust/liblttng-ust.la
This page took 0.024102 seconds and 4 git commands to generate.