Use libtool syntax in LDADD
[lttng-ust.git] / liblttng-ust-python-agent / Makefile.am
index 726ffe4e6d88a55cca00ea112bff989a179f9d8d..077e50c5fb4d581eddf31151dd994161f6d9581a 100644 (file)
@@ -1,8 +1,10 @@
 # tracepoint provider: always built/installed (does not depend on Python per se)
 AM_CPPFLAGS = -I$(top_srcdir)/include/ \
        -I$(top_builddir)/include/
-AM_CFLAGS = -fno-strict-aliasing
+AM_CFLAGS += -fno-strict-aliasing
+
 lib_LTLIBRARIES = liblttng-ust-python-agent.la
+
 liblttng_ust_python_agent_la_SOURCES = lttng_ust_python.c lttng_ust_python.h
-liblttng_ust_python_agent_la_LIBADD = -lc -llttng-ust \
-       -L$(top_builddir)/liblttng-ust/.libs
+liblttng_ust_python_agent_la_LIBADD = -lc \
+       $(top_builddir)/liblttng-ust/liblttng-ust.la
This page took 0.024342 seconds and 4 git commands to generate.