Add probe provider unregister function
[lttng-ust.git] / liblttng-ust-libc-wrapper / Makefile.am
index 4fdcedb75ae3de24c6caba97e5483385afe34ac0..e73b4d88ad52c9a8f634c6ae316e953937f12e2c 100644 (file)
@@ -1,7 +1,8 @@
 AM_CPPFLAGS = -I$(top_srcdir)/include -I$(top_builddir)/include
-AM_CFLAGS = -fno-strict-aliasing
+AM_CFLAGS += -fno-strict-aliasing
 
-lib_LTLIBRARIES = liblttng-ust-libc-wrapper.la
+lib_LTLIBRARIES = liblttng-ust-libc-wrapper.la \
+  liblttng-ust-pthread-wrapper.la
 liblttng_ust_libc_wrapper_la_SOURCES = \
        lttng-ust-malloc.c \
        ust_libc.h
@@ -9,11 +10,20 @@ liblttng_ust_libc_wrapper_la_LIBADD = \
        -L$(top_builddir)/liblttng-ust/.libs \
        -llttng-ust
 
+liblttng_ust_pthread_wrapper_la_SOURCES = \
+       lttng-ust-pthread.c \
+       ust_pthread.h
+liblttng_ust_pthread_wrapper_la_LIBADD = \
+       -L$(top_builddir)/liblttng-ust/.libs \
+       -llttng-ust
+
 if LTTNG_UST_BUILD_WITH_LIBDL
 liblttng_ust_libc_wrapper_la_LIBADD += -ldl
+liblttng_ust_pthread_wrapper_la_LIBADD += -ldl
 endif
 if LTTNG_UST_BUILD_WITH_LIBC_DL
 liblttng_ust_libc_wrapper_la_LIBADD += -lc
+liblttng_ust_pthread_wrapper_la_LIBADD += -lc
 endif
 
 noinst_SCRIPTS = run
This page took 0.024627 seconds and 4 git commands to generate.