Use a variable to select the dlopen lib in Makefiles
[lttng-ust.git] / liblttng-ust-libc-wrapper / Makefile.am
index 6220f76c6c64ec2d6d239f87ee0f4270f08d9c68..e510a11a2c319c0e01493d431977b74ef45f75fd 100644 (file)
@@ -1,13 +1,26 @@
-AM_CPPFLAGS = -I$(top_srcdir)/include
-AM_CFLAGS = -fno-strict-aliasing
+AM_CPPFLAGS = -I$(top_srcdir)/include -I$(top_builddir)/include
+AM_CFLAGS += -fno-strict-aliasing
+
+lib_LTLIBRARIES = liblttng-ust-libc-wrapper.la \
+  liblttng-ust-pthread-wrapper.la
 
-lib_LTLIBRARIES = liblttng-ust-libc-wrapper.la
 liblttng_ust_libc_wrapper_la_SOURCES = \
        lttng-ust-malloc.c \
        ust_libc.h
-liblttng_ust_libc_wrapper_la_LIBADD = -ldl \
+
+liblttng_ust_libc_wrapper_la_LIBADD = \
+       -L$(top_builddir)/liblttng-ust/.libs \
+       -llttng-ust \
+       $(DL_LIBS)
+
+liblttng_ust_pthread_wrapper_la_SOURCES = \
+       lttng-ust-pthread.c \
+       ust_pthread.h
+
+liblttng_ust_pthread_wrapper_la_LIBADD = \
        -L$(top_builddir)/liblttng-ust/.libs \
-       -llttng-ust
+       -llttng-ust \
+       $(DL_LIBS)
 
 noinst_SCRIPTS = run
 EXTRA_DIST = run
This page took 0.030839 seconds and 4 git commands to generate.