Add probe provider unregister function
[lttng-ust.git] / liblttng-ust-java / Makefile.am
index fee9b7d28b79b2f2567e91c57124b7c3ac9d65b1..399b62cac1d06cb322d3b549c9998523d72027fe 100644 (file)
@@ -7,7 +7,7 @@ dist_noinst_JAVA = $(pkgpath)/LTTngUst.java
 jar_DATA = $(jarfile)
 BUILT_SOURCES = org_lttng_ust_LTTngUst.h
 
-AM_CPPFLAGS = -I$(top_srcdir)/include
+AM_CPPFLAGS = -I$(top_srcdir)/include -I$(top_builddir)/include $(JNI_CPPFLAGS)
 lib_LTLIBRARIES = liblttng-ust-java.la
 liblttng_ust_java_la_SOURCES = LTTngUst.c lttng_ust_java.h
 nodist_liblttng_ust_java_la_SOURCES = org_lttng_ust_LTTngUst.h
@@ -20,7 +20,7 @@ $(jarfile): classnoinst.stamp
 org_lttng_ust_LTTngUst.h: jni-header.stamp
 
 jni-header.stamp: $(dist_noinst_JAVA)
-       $(JAVAH) -cp $(srcdir) $(JAVAHFLAGS) org.lttng.ust.LTTngUst && \
+       $(JAVAH) -classpath $(srcdir) $(JAVAHFLAGS) org.lttng.ust.LTTngUst && \
        echo "JNI header generated" > jni-header.stamp
 
 all-local: org_lttng_ust_LTTngUst.h
This page took 0.02267 seconds and 4 git commands to generate.