Fix: Don't override user variables within the build system
[lttng-ust.git] / liblttng-ust-dl / Makefile.am
index c408fddb35f10845d503a08c02e6dbc67c862d03..c0168f395bf9e4a093339d3e61a703e397e39f39 100644 (file)
@@ -1,8 +1,11 @@
-AM_CPPFLAGS = -I$(top_srcdir)/include
-AM_CFLAGS = -fno-strict-aliasing
+AM_CPPFLAGS = -I$(top_srcdir)/include -I$(top_builddir)/include
+AM_CFLAGS += -fno-strict-aliasing
 
 lib_LTLIBRARIES = liblttng-ust-dl.la
-liblttng_ust_dl_la_SOURCES = ustdl.c
+liblttng_ust_dl_la_SOURCES = \
+       lttng-ust-dl.c \
+       ust_dl.c \
+       ust_dl.h
 liblttng_ust_dl_la_LIBADD = \
        $(top_builddir)/liblttng-ust/liblttng-ust.la
 
@@ -13,4 +16,4 @@ if LTTNG_UST_BUILD_WITH_LIBC_DL
 liblttng_ust_dl_la_LIBADD += -lc
 endif
 
-libustdl_CFLAGS = -DUST_COMPONENT=liblttng-ust-dl -fno-strict-aliasing
+liblttng_ust_dl_la_CFLAGS = -DUST_COMPONENT=liblttng-ust-dl $(AM_CFLAGS)
This page took 0.023265 seconds and 4 git commands to generate.