Use a variable to select the dlopen lib in Makefiles
[lttng-ust.git] / liblttng-ust-dl / Makefile.am
index c0168f395bf9e4a093339d3e61a703e397e39f39..1f6d166a013ae4230f9cb22405fa0d0f899f9df9 100644 (file)
@@ -6,14 +6,9 @@ liblttng_ust_dl_la_SOURCES = \
        lttng-ust-dl.c \
        ust_dl.c \
        ust_dl.h
-liblttng_ust_dl_la_LIBADD = \
-       $(top_builddir)/liblttng-ust/liblttng-ust.la
 
-if LTTNG_UST_BUILD_WITH_LIBDL
-liblttng_ust_dl_la_LIBADD += -ldl
-endif
-if LTTNG_UST_BUILD_WITH_LIBC_DL
-liblttng_ust_dl_la_LIBADD += -lc
-endif
+liblttng_ust_dl_la_LIBADD = \
+       $(top_builddir)/liblttng-ust/liblttng-ust.la \
+       $(DL_LIBS)
 
 liblttng_ust_dl_la_CFLAGS = -DUST_COMPONENT=liblttng-ust-dl $(AM_CFLAGS)
This page took 0.02273 seconds and 4 git commands to generate.