Use a variable to select the dlopen lib in Makefiles
[lttng-ust.git] / liblttng-ust-cyg-profile / Makefile.am
index 3130282d2fd383cf8c326404cd1e2dc1e4b994bc..0ed2cd9cae6169f8646368d2b6b6b12128fad540 100644 (file)
@@ -7,25 +7,20 @@ lib_LTLIBRARIES = liblttng-ust-cyg-profile.la \
 liblttng_ust_cyg_profile_la_SOURCES = \
        lttng-ust-cyg-profile.c \
        lttng-ust-cyg-profile.h
+
 liblttng_ust_cyg_profile_la_LIBADD = \
        -L$(top_builddir)/liblttng-ust/.libs \
-       -llttng-ust
+       -llttng-ust \
+       $(DL_LIBS)
 
 liblttng_ust_cyg_profile_fast_la_SOURCES = \
        lttng-ust-cyg-profile-fast.c \
        lttng-ust-cyg-profile-fast.h
+
 liblttng_ust_cyg_profile_fast_la_LIBADD = \
        -L$(top_builddir)/liblttng-ust/.libs \
-       -llttng-ust
-
-if LTTNG_UST_BUILD_WITH_LIBDL
-liblttng_ust_cyg_profile_la_LIBADD += -ldl
-liblttng_ust_cyg_profile_fast_la_LIBADD += -ldl
-endif
-if LTTNG_UST_BUILD_WITH_LIBC_DL
-liblttng_ust_cyg_profile_la_LIBADD += -lc
-liblttng_ust_cyg_profile_fast_la_LIBADD += -lc
-endif
+       -llttng-ust \
+       $(DL_LIBS)
 
 noinst_SCRIPTS = run run-fast
 EXTRA_DIST = run run-fast
This page took 0.022478 seconds and 4 git commands to generate.