Move "hello-static-lib" to doc/examples and add non-automake Makefiles
[lttng-ust.git] / doc / examples / Makefile.am
index 2dc042a0945f71f8473d604457a363a2cee305bb..e9dd170d07b59df84e128f67e5a9f9f9a62221e5 100644 (file)
@@ -1,6 +1,12 @@
+SUBDIRS = easy-ust demo hello-static-lib
+
+doc_examplesdir = ${docdir}/examples
 doc_examples_easy_ustdir = ${docdir}/examples/easy-ust
 doc_examples_gen_tpdir = ${docdir}/examples/gen-tp
 doc_examples_demodir = ${docdir}/examples/demo
+doc_examples_hello_static_libdir = ${docdir}/examples/hello-static-lib
+
+dist_doc_examples_DATA = README
 
 dist_doc_examples_easy_ust_DATA = easy-ust/Makefile \
        easy-ust/sample.c \
@@ -19,3 +25,12 @@ dist_doc_examples_demo_DATA = demo/demo.c \
        demo/ust_tests_demo2.h \
        demo/ust_tests_demo3.h \
        demo/ust_tests_demo.h
+
+dist_doc_examples_hello_static_lib_DATA = hello-static-lib/Makefile \
+       hello-static-lib/hello.c \
+       hello-static-lib/README \
+       hello-static-lib/ust_tests_hello.h \
+       hello-static-lib/tp.c
+
+BUILD_EXAMPLES_FROM_TREE = 1
+export
This page took 0.022903 seconds and 4 git commands to generate.