Pass the CC variable to the example Makefiles
[lttng-ust.git] / doc / examples / Makefile.am
index 583909b65a8a97c211c7c44623bac968285c2663..1d353facf375610892d7e75777f34ff0db11e4d6 100644 (file)
@@ -34,15 +34,28 @@ if NO_SHARED
 # Don't build examples if shared libraries support was explicitly
 # disabled.
 else
-SUBDIRS_PROXY = easy-ust demo hello-static-lib
+# Copies are for VPATH build support
+SUBDIRS_PROXY = easy-ust demo gen-tp hello-static-lib
 
 all-local:
+       @if [ x"$(srcdir)" != x"$(builddir)" ]; then \
+               cp -f $(srcdir)/Makefile.examples.template $(builddir); \
+               for subdir in $(SUBDIRS_PROXY); do \
+                       cp -fR $(srcdir)/$$subdir $(builddir); \
+               done; \
+       fi
        for subdir in $(SUBDIRS_PROXY); do \
-               cd $$subdir && $(MAKE) AM_CPPFLAGS="-I../../../include/" AM_LDFLAGS='-L../../../liblttng-ust/.libs/ -Wl,-rpath="$(PWD)/../../liblttng-ust/.libs/"' $(AM_MAKEFLAGS) all; cd ..; \
+               (cd $$subdir && $(MAKE) AM_CC="$(CC)" AM_CPPFLAGS="$(CPPFLAGS) -I../../../include/" AM_CFLAGS='$(CFLAGS)' AM_LDFLAGS='$(LDFLAGS) -L../../../liblttng-ust/.libs/ -Wl,-rpath="$(PWD)/../../liblttng-ust/.libs/"' LTTNG_GEN_TP_PATH="../../../tools/" $(AM_MAKEFLAGS) all && cd ..) || exit 1; \
        done
 
 clean-local:
        for subdir in $(SUBDIRS_PROXY); do \
-               cd $$subdir && $(MAKE) $(AM_MAKEFLAGS) clean; cd ..; \
+               (cd $$subdir && $(MAKE) $(AM_MAKEFLAGS) clean && cd ..) || exit 1; \
        done
+       @if [ x"$(srcdir)" != x"$(builddir)" ]; then \
+               for subdir in $(SUBDIRS_PROXY); do \
+                       rm -rf $(builddir)/$$subdir; \
+               done; \
+               rm -f $(builddir)/Makefile.examples.template; \
+       fi
 endif
This page took 0.024028 seconds and 4 git commands to generate.