tests: Add C versions of gen-ust-events-constructor
[lttng-tools.git] / tests / utils / testapp / gen-ust-events-constructor / Makefile.am
index a855b25fe8ad4ab2f1ef6fec2bcb71ac49b942ba..6c09cf58575cb5ec9be7d6fc76a663fbbb521229 100644 (file)
@@ -12,6 +12,12 @@ WARN_FLAGS = \
 AM_CFLAGS += $(WARN_FLAGS)
 AM_CXXFLAGS += $(WARN_FLAGS)
 
+noinst_LTLIBRARIES = libtp-a-provider.la libtp-a-define.la \
+       libtp-a_c-provider.la libtp-a_c-define.la
+noinst_PROGRAMS = gen-ust-events-constructor-a \
+       gen-ust-events-c-constructor-a \
+       uses_heap
+
 if NO_SHARED
 # Build the shared library as a static archive if shared libraries
 # are disabled.
@@ -21,11 +27,13 @@ else
 # only built static by default
 FORCE_SHARED_LIB_OPTIONS = -module -shared -avoid-version \
                           -rpath $(abs_builddir)
+
+noinst_LTLIBRARIES += libtp-so-provider.la libtp-so-define.la \
+       libtp-so_c-provider.la libtp-so_c-define.la
+noinst_PROGRAMS += gen-ust-events-constructor-so \
+       gen-ust-events-c-constructor-so
 endif
 
-noinst_LTLIBRARIES = libtp-so-provider.la libtp-so-define.la \
-                    libtp-a-provider.la libtp-a-define.la \
-                    libtp-a_c-provider.la libtp-a_c-define.la
 
 # dynamic libraries
 libtp_so_provider_la_SOURCES = \
@@ -40,6 +48,16 @@ libtp_so_define_la_SOURCES = \
 libtp_so_define_la_LDFLAGS = \
        $(FORCE_SHARED_LIB_OPTIONS)
 
+libtp_so_c_provider_la_SOURCES = \
+       tp-so_c-provider.c \
+       tp-so_c.h
+libtp_so_c_provider_la_LDFLAGS = $(FORCE_SHARED_LIB_OPTIONS)
+
+libtp_so_c_define_la_SOURCES = \
+       tp-so_c-define.c \
+       tp-so_c.h
+libtp_so_c_define_la_LDFLAGS = $(FORCE_SHARED_LIB_OPTIONS)
+
 # static archives
 libtp_a_provider_la_SOURCES = \
        tp-a-provider.cpp \
@@ -58,9 +76,7 @@ libtp_a_c_define_la_SOURCES = \
        tp-a_c.h
 
 
-noinst_PROGRAMS = gen-ust-events-constructor \
-       uses_heap
-gen_ust_events_constructor_SOURCES = main.cpp \
+gen_ust_events_constructor_so_SOURCES = main.cpp \
        01-tp-before-define.cpp \
        02-define-tp.cpp \
        03-tp-after-define.cpp \
@@ -69,15 +85,59 @@ gen_ust_events_constructor_SOURCES = main.cpp \
        obj.cpp \
        obj.h \
        tp.h
-gen_ust_events_constructor_LDADD = $(UST_LIBS) \
-               $(builddir)/libtp-so-define.la \
-               $(builddir)/libtp-so-provider.la \
-               $(builddir)/libtp-a-define.la \
-               $(builddir)/libtp-a-provider.la \
-               $(builddir)/libtp-a_c-define.la \
-               $(builddir)/libtp-a_c-provider.la \
-               $(top_builddir)/tests/utils/libtestutils.la \
-               $(DL_LIBS)
+gen_ust_events_constructor_so_LDADD = $(UST_LIBS) \
+       $(builddir)/libtp-so-define.la \
+       $(builddir)/libtp-so-provider.la \
+       $(builddir)/libtp-so_c-define.la \
+       $(builddir)/libtp-so_c-provider.la \
+       $(top_builddir)/tests/utils/libtestutils.la \
+       $(DL_LIBS)
+
+gen_ust_events_c_constructor_so_SOURCES = main_c-so.c \
+       01-c-tp-before-define.c \
+       02-c-define-tp.c \
+       03-c-tp-after-define.c \
+       04-c-tp-provider.c \
+       05-c-tp-after-provider.c \
+       tp.h
+gen_ust_events_c_constructor_so_LDADD = $(UST_LIBS) \
+       $(builddir)/libtp-so-define.la \
+       $(builddir)/libtp-so-provider.la \
+       $(builddir)/libtp-so_c-define.la \
+       $(builddir)/libtp-so_c-provider.la \
+       $(top_builddir)/tests/utils/libtestutils.la \
+       $(DL_LIBS)
+
+gen_ust_events_constructor_a_SOURCES = main-a.cpp \
+       01-tp-before-define.cpp \
+       02-define-tp.cpp \
+       03-tp-after-define.cpp \
+       04-tp-provider.cpp \
+       05-tp-after-provider.cpp \
+       obj-a.cpp \
+       obj-a.h \
+       tp.h
+gen_ust_events_constructor_a_LDADD = $(UST_LIBS) \
+       $(builddir)/libtp-a-define.la \
+       $(builddir)/libtp-a-provider.la \
+       $(builddir)/libtp-a_c-define.la \
+       $(builddir)/libtp-a_c-provider.la \
+       $(top_builddir)/tests/utils/libtestutils.la \
+       $(DL_LIBS)
+
+gen_ust_events_c_constructor_a_SOURCES = main_c-a.c \
+       01-c-tp-before-define.c \
+       02-c-define-tp.c \
+       03-c-tp-after-define.c \
+       04-c-tp-provider.c \
+       05-c-tp-after-provider.c \
+       tp.h
+gen_ust_events_c_constructor_a_LDADD = $(UST_LIBS) \
+       $(builddir)/libtp-a_c-define.la \
+       $(builddir)/libtp-a_c-provider.la \
+       $(top_builddir)/tests/utils/libtestutils.la \
+       $(DL_LIBS)
 
 uses_heap_SOURCES = uses_heap.cpp
+
 endif
This page took 0.023974 seconds and 4 git commands to generate.