Fix: sessiond: crash when sending data_pending to an active session
[lttng-tools.git] / tests / utils / testapp / Makefile.am
index be2758de3ecc4f5032e1fa5f639eb0624c032668..b58c233d5fcca555652456b4c4b50b5bb93ccb8d 100644 (file)
@@ -1,2 +1,29 @@
-SUBDIRS = gen-ust-events gen-ust-nevents
+# SPDX-License-Identifier: GPL-2.0-only
+SUBDIRS = \
+         gen-data-pending \
+         gen-kernel-test-events \
+         gen-py-events \
+         gen-syscall-events \
+         gen-ust-events \
+         gen-ust-nevents \
+         gen-ust-nevents-str \
+         gen-ust-tracef \
+         userspace-probe-elf-binary \
+         userspace-probe-elf-cxx-binary \
+         gen-ust-events-constructor
 
+if TEST_SDT_UPROBE
+SUBDIRS += userspace-probe-sdt-binary
+endif # TEST_SDT_UPROBE
+
+if HAVE_MODULES_USERSPACE_CALLSTACK_CONTEXT
+SUBDIRS += gen-syscall-events-callstack
+endif # HAVE_MODULES_USERSPACE_CALLSTACK_CONTEXT
+
+if IS_LINUX
+SUBDIRS += \
+         gen-ns-events \
+         gen-ust-events-ns
+endif # IS_LINUX
+
+noinst_HEADERS = signal-helper.hpp
This page took 0.023403 seconds and 4 git commands to generate.